Application Perf Mgmt (BAC / BSM) User Discussions
cancel

Business Application CI not obtaining status

Absent Member.. ABezev Absent Member..
Absent Member..

Business Application CI not obtaining status

Hello colleagues, we are struggling with strange issue regarding status recieving in OMi.

The environment is the following:

OMi 10.10 IP1 (on RHEL 6.5)

BSM 9.26 (on RHEL 6.5)

BPM 9.26 + VuGen 12.50 (on Windows 2008R2)

The situation is the following: We are monitoring Oracle Flexcube corebanking interface via Vugen script (simply checking a status in http web form where it is 'UP' or 'DOWN'.) We created tree in OMi where on top is Bussines Application <-- Bussiness transaction flow <-- Business transaction.

Regarding the topology everything is OK , Business Aplication CI's are syncing from BSM to OMi. The problem is: when trying to sync status from BSM to OMi nothing happens. 

We have applied workaround the VuGen script sends event alerts to OMi. But due to our oppinion this kind of status synchronization is supported OOTB.

Any recomendations or hints provided by your side will be appreciated.

Thank you in advance

Adrian

 

6 REPLIES
Micro Focus Expert
Micro Focus Expert

Re: Business Application CI not obtaining status

Hi Adrian,

when integrating BSM / OMi the integration should create CI Statis Alerts to be sent from BSM to OMi.

In your BSM, check whether you see two CI status alerts (Improved / Worsend CI Status forwarded to Omi) under Admin -> Service Health -> CI Status Alerts

If these are missing, check the integration documentation and ensure that all steps have been followed.

Best Regards

     Bernhard

Absent Member.. ABezev Absent Member..
Absent Member..

Re: Business Application CI not obtaining status

Hello Bernhard,

these steps have been done already:

BSM.png

Best regards

Adrian Bezev 

Micro Focus Expert
Micro Focus Expert

Re: Business Application CI not obtaining status

hi,

the Event triggered from the EUM Alert will NOT color the BizApp CI. the reason - these events are coming with ETI which is NOT an HI. this behavior is by-design since we dont want the BizApp CI to be "colored" both by Alerts and by status propagation from the Business Transactions.

did you follow all the steps as Bernhard suggested? There is additional step on OMi side to modify the KPI Assignments for Business Application. make sure you didnt forget it.

Jeevitha Trusted Contributor.
Trusted Contributor.

Re: Business Application CI not obtaining status

 Hi Team,

 

I did all the mentioned activities in APM and OMI,still color change is not happening in OMI.Please help

Micro Focus Expert
Micro Focus Expert

Re: Business Application CI not obtaining status

APM only sends events to OMi when there is status change. only when the first event will arrive to OMi then you will see KPI status in OMi.

if the BizApp in APM already changed status then i recommend to submit support case for further investigation.

David_H Frequent Contributor.
Frequent Contributor.

Re: Business Application CI not obtaining status

I'm facing the exact same problem with OMi.  I have tried everything suggested by MF.  Did you get this resolved?  If, so, would you mind sharing?  Thanks!