Maintenance is complete- We've moved from the saas.hpe.com domain to softwaregrp.com click to read more
As part of our journey to complete our separation work and our future integration with Micro Focus, we've now updated our domain for the community. This is an interim step, which will be followed by a series of future update / improvements: - Piloting Idea boards - Refreshing the entire UI. (more to come later) - and more
Application Perf Mgmt (BAC / BSM) Practitioners Forum
cancel

SiteScope 11.40 - APM 9.40, "No empty profiles available"

SOLVED
Go to solution
dasomm
Super Contributor.

SiteScope 11.40 - APM 9.40, "No empty profiles available"

Hi all,

I have a problem integrating SiteScope 11.40 and APM 9.40.
I imported the necessary SAM license file in APM, created a profile DB and an entry for the SIteScope server in SAM. From the APM side everything works fine, I see the SiteScope server stats under Summary and can also access SiteScope through SAM.

But when I try to create the APM integration under SiteScope Preferences I get "No empty profiles available". 
There is no FW between the two servers, I use HTTP for APM and I see the proflie DB on the MS SQL server. 
I'm using OA 12.04 on the SiteScope server. Nslookup against the APM server address (DNS alias) works fine, and I've also tried entering the APM server without the alias.

Any suggestions?

6 REPLIES
Dmitry Shevchenko
Micro Focus Expert

Re: SiteScope 11.40 - APM 9.40, "No empty profiles available"

>>>But when I try to create the APM integration under SiteScope Preferences I get "No empty profiles available". 

Why are you trying to do it? Once you create a SAM profile in APM, APM connects to SiteScope and creates a corresponding entry under SiteScope Integration Preferences. This is how it's designed to work.

A quote from APM 9.40 Application Administration guide:

After the integration has completed successfully, the SiteScope Profile is added to the left pane in SAM Admin. The profile status is blue (not up-to-date) because SiteScope has not yet sent any data or samples to APM. In SiteScope, the APM host is added to Preferences > Integration Preferences, and the HPE Integration Settings panel is displayed in the monitor Properties page.

dasomm
Super Contributor.

Re: SiteScope 11.40 - APM 9.40, "No empty profiles available"


Dmitry Shevchenko wrote:

Why are you trying to do it? Once you create a SAM profile in APM, APM connects to SiteScope and creates a corresponding entry under SiteScope Integration Preferences. This is how it's designed to work.

A quote from APM 9.40 Application Administration guide:

After the integration has completed successfully, the SiteScope Profile is added to the left pane in SAM Admin. The profile status is blue (not up-to-date) because SiteScope has not yet sent any data or samples to APM. In SiteScope, the APM host is added to Preferences > Integration Preferences, and the HPE Integration Settings panel is displayed in the monitor Properties page.


The answer to your question is that in this case APM is NOT added to Preferences->Integration Preferences on the SiS server.  Therefore I thought creating the integration manually by pressing the button for "Get Available Profiles" might do the trick. 
The only entry I have under Preferences->Integration Preferences is the one for OMI (10.62), which works fine. 
I see the HPE Integration Settings panel in the monitor Properties page, but the ´APM Integration Data and Topology Settings´part is inactive. 

 

Dmitry Shevchenko
Micro Focus Expert

Re: SiteScope 11.40 - APM 9.40, "No empty profiles available"

>>>The only entry I have under Preferences->Integration Preferences is the one for OMI (10.62), which works fine. 

What's the name of this entry? BSM Integration or OM integration?

dasomm
Super Contributor.

Re: SiteScope 11.40 - APM 9.40, "No empty profiles available"

"HPE Operations Manager Integration"

In Audit.log in SiS from when I added the SiS server in APM SAM:
2017-10-13 15:52:13 - User: admin. Operation performed: SiteScope was registered to APM server 'hpapmgw-q.preprod.local' with profileName 'SiteScopeQ'

In Error.log in SiS:

"2017-10-13 15:52:18,192 [http-bio-8080-exec-3] (SamAdminSilentLoginUtils.java:45) ERROR - SilentLogin parameter with key= JSESSIONID is null.
2017-10-13 15:52:18,192 [http-bio-8080-exec-3] (SamAdminSilentLoginUtils.java:45) ERROR - SilentLogin parameter with key= sis is null.
2017-10-13 15:52:18,192 [http-bio-8080-exec-3] (SamAdminSilentLoginUtils.java:45) ERROR - SilentLogin parameter with key= LWSSO_COOKIE_KEY is null."

Looks very similar to this one:

https://softwaresupport.hpe.com/group/softwaresupport/search-result/-/facetsearch/document/LID/QCCR1I59606

In this case APM is indeed able to log in to SiS.

Dmitry Shevchenko
Micro Focus Expert

Re: SiteScope 11.40 - APM 9.40, "No empty profiles available"

It's clear that SAM profile registration process went wrong. This is what you need to troubleshoot via log files (put in DEBUG if necessary) on both APM and SiteScope sides. Not to try adding BSM Integration entry manually in SiteScope Integration Preferences. 

dasomm
Super Contributor.
Solution

Re: SiteScope 11.40 - APM 9.40, "No empty profiles available"

Support had the answer; more Java memory. Ran the config tool-sizing, created a new SAM instance using the same profile DB as before, and it worked fine.  

Thanks for the feedback on the issue.