Maintenance is complete- We've moved from the saas.hpe.com domain to softwaregrp.com click to read more
As part of our journey to complete our separation work and our future integration with Micro Focus, we've now updated our domain for the community. This is an interim step, which will be followed by a series of future update / improvements: - Piloting Idea boards - Refreshing the entire UI. (more to come later) - and more
Application Perf Mgmt (BAC / BSM) Practitioners Forum
cancel

Unable to access APM interface

SOLVED
Go to solution
Highlighted
yangnigon
Honored Contributor.

Unable to access APM interface

Hello community,

I have a strange behavior when accessing APM interface.

I disabled the pop-up blocker but it did not help much. I've tried both firefox and IE but the same result.

Please let me know if anybody ran into this issue and was able to resolve it.

Thanks,

10 REPLIES
Asaf Shechter
Micro Focus Expert

Re: Unable to access APM interface

you need to provide more details, such as version, how many servers you have, whether they all show "server is ready" in status page, etc.

yangnigon
Honored Contributor.

Re: Unable to access APM interface

Here is an additional information:

There are 5 servers (3 GW and 2 DPS).

All servers are ready with green lights as APM status shows "server is ready".

IE version is 11 and Firefox version is ESR 38.2.0

APMs are installed in Windows Server 2012 R2

If you need more details information, please let me know.

Thanks,

 

Asaf Shechter
Micro Focus Expert

Re: Unable to access APM interface

please provide deployment report:

goto jmx-console (GW or DPS, port 29000) > BSMServerDeployment > displayDeploymentReport

you can mask servers names.

yangnigon
Honored Contributor.

Re: Unable to access APM interface

Please find the attachment.

Thanks,

Asaf Shechter
Micro Focus Expert

Re: Unable to access APM interface

all seem fine. 

can you also attach the result of jmx-console service=BSMConfigurationValidator?

Asaf Shechter
Micro Focus Expert

Re: Unable to access APM interface

also, on a careful look i saw that the URL on login page is using http but the popup went to port 443... I think your configuration is wrong

yangnigon
Honored Contributor.

Re: Unable to access APM interface

yes, i think something went wrong somewhere.

so how can I resolve this issue? should I re-run the configuration wizard and do re-mapping?

Like i said it in earlier post, everything was configured correctly but then i added port 443 and it all went south.

https://community.saas.hpe.com/t5/Application-Perf-Mgmt-BAC-BSM/Is-there-a-way-to-revert-back-to-stage-before-changes-were-made/m-p/1614990

If the configuration is wrong, how to resolve and make things work the way it was. I want to revert it back so that everything is in working condition.

Thanks,

yangnigon
Honored Contributor.

Re: Unable to access APM interface

Asah,

I defintiely think I know what the issue is here.

I can fix this if I am able to access to APM interface inside. However, that is the problem that I am encountering. It won't let me get inside the APM interface.

So I am trying to figure out how to get inside of APM interface so that I can make changes accordingly.

The question here is that is there any backdoor or any other way of accessing APM interface?

If not, what can be done to make things work?

Thanks,

Asaf Shechter
Micro Focus Expert
Solution

Re: Unable to access APM interface

as you can see from the configuration validator report you have wrong settings for users URL.

there is no backdoor. you have to fix these settings from jmx-console or directly in the DB.

as mentioned in your previous posts - open support case if you need further help.

yangnigon
Honored Contributor.

Re: Unable to access APM interface

Okay, I finally resolved the issue and wanted to post the resolution since so many ppl trying to help me.

so, long story short... there was some mix-up in the configuration as Asaf mentioned on the post.

I was working with DBA to clean up the Management DB, modifed table SETTING_PARAMETER
direct.centers.server.url
direct.core.server.url
virtual.centers.server.url
virtual.core.server.url

After this, go to the jmx-console AND set the enable.proxy.server = false.

It looks like the issue was the reverse proxy was set to true without configuration. So, I changed this value to false and now I am able to access APM interface without an issue.

Once again, thanks everyone for your valuable information.

Thanks!