Data Protector User Discussions
cancel

"Backup failed because unable to utilize CBT as it was required"

Gamut Super Contributor.
Super Contributor.

"Backup failed because unable to utilize CBT as it was required"

I'm on DP 9.09_115 Linux (CM and MM). All of a sudden, VMware jobs are failing with:

    "Backup failed because unable to utilize CBT as it was required"

But only on 1 of 6 cell managers. No known changes were done to the VMware environment yesterday, nor any relevant changes to the cell manager. Last week had a relevant change: upgrade from vSphere 6.0 to 6.5, but I fail to see how this would cause these problems 6 days later...

 

My best guess is that VMware is somehow to blame, and I can use your assistance. Perhaps you have seen this problem too, and might be able to share pointers/workarounds/solutions.

I am also looking for a workaround. In particular: how can I disable the forcing of CBT? I know the incremental backups will be slow as hell whem CBT cannot be used, but if the problem persists, a slow backup beats no backup...

3 REPLIES
Gamut Super Contributor.
Super Contributor.

Re: "Backup failed because unable to utilize CBT as it was required"

I found a way to enable non-CBT backups in https://support.hpe.com/hpsc/doc/public/display?docId=c04318203.

* Go to the VMware job.

* Right mouse button on the VM of your choice.

* Select "Configure Virtual Machines...".

* Uncheck "Use common settings for selected VM".

* Keep "Use changed block tracking" checked.

* Check "Allow fallback to non-CBT backups".

* Hit "OK".

 

I tried it on one the VM's that could not be backed up, and DP was able to back it up.

 

Gamut Super Contributor.
Super Contributor.

Re: "Backup failed because unable to utilize CBT as it was required"

Since a loads of VM's have this backup problem (but certainly not all), I didn't want to enable the fallback for every single failing VM. Fortunately, DP can do that:

* Go to any VMware job.
* Right mouse button on any VM.
* Select "Configure Virtual Machines...".
* Select the following virtual machine: "(Common VM Settings)"
* Keep "Use changed block tracking" checked.
* Check "Allow fallback to non-CBT backups".
* Hit "OK".
 
IIRC, this will non only change to non-CBT backup for the job, but for ALL DP VMware jobs.
Gamut Super Contributor.
Super Contributor.

Re: "Backup failed because unable to utilize CBT as it was required"

Update:

The problem started when the ESX nodes were upgraded from 6.0 to 6.5.

 

Furthermore, the problem seems to disappear once a full is made instead of an incremental.

 

Since the problems disappear after fulls, I will not determine the root cause. If the problem is gone, it is good enough for me at this moment.

Top Contributors Last 30 Days