Diagnostics Software User Discussions
cancel

Diagnostic jave agent not reflected on Diagnostic server

dhuri_nikhil Absent Member.
Absent Member.

Diagnostic jave agent not reflected on Diagnostic server

We have installed diagnostics java agent for a application which has embedded jre as well as embedded web application server i.e tomcat 7.The installation and configuration is done properly but the agent is not reflected in the diagnostics server.

Here are the details:

Path of JVM :- C:\SASHOME\SASPrivateJavaRuntimeEnvironment\9.4\jre\bin\

Application Server Path:- C:\SASHOME\SASWebApplicationServer\9.4\tomcat-7.0.30.A.RELEASE

Web Application server:- Tomcat7

Application Platform:- Java

JVM Version:- 1.7

We have restarted the application server after the installation.

 

 

6 REPLIES
Super Contributor.. solanoh Super Contributor..
Super Contributor..

Re: Diagnostic jave agent not reflected on Diagnostic server

What type of instrumentation did you used? The automatics or did you did the manual instrumentation on the catalina.[bat|sh]?

 

dhuri_nikhil Absent Member.
Absent Member.

Re: Diagnostic jave agent not reflected on Diagnostic server

We did automatic instrumentation 

Super Contributor.. solanoh Super Contributor..
Super Contributor..

Re: Diagnostic jave agent not reflected on Diagnostic server

The automatics, is going to edit the catalina file. Please check if the instrumentation was added.

If not follow the attached document in the page 56 'Example 6: Configuring Tomcat Application Sever for Monitoring'.

And  incase it is in please and you already restarted the app server, please upload a copy of the agent /etc and /log directores.

dhuri_nikhil Absent Member.
Absent Member.

Re: Diagnostic jave agent not reflected on Diagnostic server

Hi Solanoh,

Please find the attached etc & log folder from Java agent server. please check & let me know the next action item.

Regards,

Nikhil.

dhuri_nikhil Absent Member.
Absent Member.

Re: Diagnostic jave agent not reflected on Diagnostic server

Hi Solanoh,

We are waiting for your kind response. did you get anything on this issue.

 

Regards,

Nikhil.

Super Contributor.. solanoh Super Contributor..
Super Contributor..

Re: Diagnostic jave agent not reflected on Diagnostic server

My apologies, I was out of the office.

 

I was checking the logs and it looks that the probe was started on the 2016/01/20 just for few seconds and then it was shutdown.

Can you please check that the instrumentation still in place and also that the application is running? If possible make a restart and send me a new copy of the logs directory.

You can confirm this by checking the log\DGETCPRSVA01\probe.log the probe never tried to registrar to the commander. You can compare it with the \log\TestProbe-0\probe.log on which it did the registrar process with the commanding server http://dgetcprbac01.dget.local:2006/commander/registrar