LoadRunner User Discussions
cancel

Response time in Analysis is not correct

SOLVED
Go to solution
Highlighted
GeethaThangaraj Trusted Contributor.
Trusted Contributor.

Response time in Analysis is not correct

Hi,

I started to execute my script in Controller ( first for single user with multiple iteration), I have a search scenario in my truclient script. The search takes nearly 5 mins , i have done this using wait for object and verify object.

In the search transaction, it has 3 steps (i) clicking search button , (ii) waiting for an object and (iii) verifying the object.

It takes nearly 5 mins and in the controller, the response time corresponding to the Search transaction is displayed correctly and showed as 300 secs, but when i collate the results in Analysis, everytime the search transaction response time is shown as < 1 sec.

I tried it multiple times and still experiencing the same issue.

I want the Analysis to collate the results and display the proper repsponse time that it is taken for searching. 

Please update me which option i need to select in the start and end transaction. My last step for that transactiuon is verifying a object after search.

Kindly help to resolve this issue.

 

Thanks & Regards,

Geetha

1 ACCEPTED SOLUTION

Accepted Solutions
Micro Focus Expert Shlomi Nissim
Micro Focus Expert
Solution

Re: Response time in Analysis is not correct

Hi,

Can you please include think time in the Analysis Session to see if it changes anything?
1. Choose "Set Global Filter" from Analysis File Menu. 
2. Scroll to the bottom of the filter conditions
3. Choose the Think TIme option and check "Include Think Time"

If it solves the issue it means TruClient reports "Wait for Object" as think time while it shouldn't. I believe there used to be an issue like that which was solved in a later version. Which version do you use?

Regards,
Shlomi

2 REPLIES
Micro Focus Expert Shlomi Nissim
Micro Focus Expert
Solution

Re: Response time in Analysis is not correct

Hi,

Can you please include think time in the Analysis Session to see if it changes anything?
1. Choose "Set Global Filter" from Analysis File Menu. 
2. Scroll to the bottom of the filter conditions
3. Choose the Think TIme option and check "Include Think Time"

If it solves the issue it means TruClient reports "Wait for Object" as think time while it shouldn't. I believe there used to be an issue like that which was solved in a later version. Which version do you use?

Regards,
Shlomi

GeethaThangaraj Trusted Contributor.
Trusted Contributor.

Re: Response time in Analysis is not correct

Hi Shlomi,

Good Morning !!!

As soon as I set the global filters and included the think time, I got the proper response Thank you so much :)

I will accept this as a solution and raise a another thread regarding 90th percentile.

Thanks & Regards,

Geetha