Do you have feedback on our new interface?
Do you have feedback on our new interface? Let us know HERE
Highlighted
GeethaThangaraj Trusted Contributor.
Trusted Contributor.
181 views

Response time in Analysis is not correct

Jump to solution

Hi,

I started to execute my script in Controller ( first for single user with multiple iteration), I have a search scenario in my truclient script. The search takes nearly 5 mins , i have done this using wait for object and verify object.

In the search transaction, it has 3 steps (i) clicking search button , (ii) waiting for an object and (iii) verifying the object.

It takes nearly 5 mins and in the controller, the response time corresponding to the Search transaction is displayed correctly and showed as 300 secs, but when i collate the results in Analysis, everytime the search transaction response time is shown as < 1 sec.

I tried it multiple times and still experiencing the same issue.

I want the Analysis to collate the results and display the proper repsponse time that it is taken for searching. 

Please update me which option i need to select in the start and end transaction. My last step for that transactiuon is verifying a object after search.

Kindly help to resolve this issue.

 

Thanks & Regards,

Geetha

0 Likes
1 Solution

Accepted Solutions
Shlomi Nissim Acclaimed Contributor.
Acclaimed Contributor.

Re: Response time in Analysis is not correct

Jump to solution

Hi,

Can you please include think time in the Analysis Session to see if it changes anything?
1. Choose "Set Global Filter" from Analysis File Menu. 
2. Scroll to the bottom of the filter conditions
3. Choose the Think TIme option and check "Include Think Time"

If it solves the issue it means TruClient reports "Wait for Object" as think time while it shouldn't. I believe there used to be an issue like that which was solved in a later version. Which version do you use?

Regards,
Shlomi

2 Replies
Shlomi Nissim Acclaimed Contributor.
Acclaimed Contributor.

Re: Response time in Analysis is not correct

Jump to solution

Hi,

Can you please include think time in the Analysis Session to see if it changes anything?
1. Choose "Set Global Filter" from Analysis File Menu. 
2. Scroll to the bottom of the filter conditions
3. Choose the Think TIme option and check "Include Think Time"

If it solves the issue it means TruClient reports "Wait for Object" as think time while it shouldn't. I believe there used to be an issue like that which was solved in a later version. Which version do you use?

Regards,
Shlomi

GeethaThangaraj Trusted Contributor.
Trusted Contributor.

Re: Response time in Analysis is not correct

Jump to solution

Hi Shlomi,

Good Morning !!!

As soon as I set the global filters and included the think time, I got the proper response Thank you so much :)

I will accept this as a solution and raise a another thread regarding 90th percentile.

Thanks & Regards,

Geetha

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.