Operations Bridge Reporter User Discussions
cancel

BOE SIA SERVICE: Creating Huge HPROF Heap Dumps in logging Directory

Highlighted
Absent Member.. OpenView_Mike Absent Member..
Absent Member..

BOE SIA SERVICE: Creating Huge HPROF Heap Dumps in logging Directory

I believe I posted about this issue before, but it has raised its ugly head again.

Given what I've seen in the SAP BOE forums, this is a known issue with the version of BOE that is packaged with the OBR 10 installation media.

However, the fix of giving the SIA service more heap is normally done via the CMC, but since the CMS.exe never starts, I cannot access the OBR Admin UI, the BI Report Portal or the CMC.

What is a manual method to give the SIA more heap?

I cannot seem to locate the correct configuration file to increase Xmx.

The HPROF files are being generated in this directory:

<BOE_HOME>\logging

Best Regards,

~ Michael Stollaire
2 REPLIES
Micro Focus Expert
Micro Focus Expert

Re: BOE SIA SERVICE: Creating Huge HPROF Heap Dumps in logging Directory

Hi

you can increase xmx via ccm.config file which is present in the linux environment at /opt/HP/BSM/BOE4/sap_bobj/ccm.config.

i am not sure why the size is increasing in your environment, i will prefer you to verify

1) is there any corruption for the file /home/shrboadmin/.businessobjects/clusterinfo.1400.properties?   just verify in this thred https://scn.sap.com/thread/3581130

2) And also OOM (out of memory) is might be because of default configuration of APS, just tune as per the guide attached. http://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/60a18b26-5e40-3010-89b3-f19b5f0b472e?overridelayout=true

let me know if you need further information.

 

Thank you

 

REgards,

krishna Rao

Absent Member.. OpenView_Mike Absent Member..
Absent Member..

Re: BOE SIA SERVICE: Creating Huge HPROF Heap Dumps in logging Directory

Thanks for the information, as this seems to be a known issue in OBR 10.0 and 10.01.

I am running the OBR APP and BOE on a Windows 2012 R2 server, FYI.

The ccm.config file does not exist on the server. I did exhaustive research before posting this topic (as always) and I saw information about this, clusterinfo.1400.properties, etc.

 

UPDATE:

 

Can someone please get me a copy of the ccm.config file? Thanks!

 

There is nothing in the links provided, about how to tell if clusterinfo.1400.properties is corrupt. There were several files called clusterinfo.1400.properties on my server that were dated at around the time I installed the application, however, how can you tell if the file is corrupt or not?

I have no files in the serverpids directory as well.

I saw a KB article on the support site about SHR and recreating the SIA when this happens, but the KB does not provide a procedure about how to do this.

I've used the MAT to evaluate the HPROFs, once again, before I started this topic, and the results are not helpful at all.

I saw this thread as well before starting this topic:

https://scn.sap.com/thread/3581130

I can run the set statement on my APP server, but there is no setenv.bat file on my server either.

Best Regards,

~ Michael Stollaire