Changes to the community structure and the menu bar
Significant changes have happened to the structure of our community and our drop down menu bar. READ ABOUT IT HERE
Performance Center User Discussions
cancel

PaintWindowsInLoad does not seem to work anymore with PC Agent in process mode

SOLVED
Go to solution
Highlighted
PeetD  Super Contributor..
 Super Contributor..

PaintWindowsInLoad does not seem to work anymore with PC Agent in process mode

Using PC version 12.55:

I run a TruClient tests with the Performance Center Agent running as a process. To enable PaintWindowsInLoad I run the script in a test with commandline option '-paint_windows_in_load 1' set. So I log on to the LG via rdp, forced the PC agent to process mode and then start the test: No browser window is opened in the rdp session on the LG. I can see the TCIE WebLauncher is running under the user with which I setup the rdp session, so that means that the browser is started and test is running, yet no replay browser window. I have used this with PC version 12.20 and it worked fine, not anymore I guess.

Has the way PainWindowsInLoad should be configured changed??

Peet

1 ACCEPTED SOLUTION

Accepted Solutions
Micro Focus Expert Shlomi Nissim
Micro Focus Expert
Solution

Re: PaintWindowsInLoad does not seem to work anymore with PC Agent in process mode

Hi Peet,

The command line option is slightly different than the entry in the Run Time Setting file (default.cfg). You should use 

-paint_window_in_load 1

not windows

Regards,

Shlomi

3 REPLIES
Micro Focus Expert Shlomi Nissim
Micro Focus Expert
Solution

Re: PaintWindowsInLoad does not seem to work anymore with PC Agent in process mode

Hi Peet,

The command line option is slightly different than the entry in the Run Time Setting file (default.cfg). You should use 

-paint_window_in_load 1

not windows

Regards,

Shlomi

PeetD  Super Contributor..
 Super Contributor..

Re: PaintWindowsInLoad does not seem to work anymore with PC Agent in process mode

Hi Shlomi,

That makes a lot of sense. It turn out that I made a typo in my notes when I all wrote it down at the time of PC 12.20. Funny PC did not complain about the typing error, it just decided not to do anything.

Thanks for point it out to me!

Regards,
Peet

Micro Focus Expert Shlomi Nissim
Micro Focus Expert

Re: PaintWindowsInLoad does not seem to work anymore with PC Agent in process mode

Hi Peet,

Just for general knowledge Performance Center does not validate the correctness of the command line arguments. It is used primariliy for feeding script code. This feature of TruClient is not something Performance Center is "aware of".

Regards,

Shlomi

 

Top Contributors Last 30 Days