Project and Portfolio Management User Discussions

Error while adding an attachment (PPM 9.13)

Absent Member.. LoisLasguignes Absent Member..
Absent Member..

Error while adding an attachment (PPM 9.13)

Hello everybody,


We are upgrading from HP PPM 7.5 to HP PPM 9.13. First upgrades works fine. We did a new upgrade on an other platform last week, and now, when we try to attach a file to a request, the following error message is displayed :

Unable to find exact physical document. Duplicate found.

(Exact message in attachment).

However, when I directly see on the server in directory attachments (the one set in server.conf file), I see the attachment that I tried to add to the request.


Do you have any ideas why this error happened ?


Thanks for your help !



Absent Member.. Niraj Prabhu Absent Member..
Absent Member..

Re: Error while adding an attachment (PPM 9.13)


Are you able to access already uploaded documents properly? For instance, try to rename the document and upload to the request, Are you getting the same error?

Are you using shared drive instead of PPM default folder structure for attachments? Check the access rights on the attachments folder.
Niraj P.
Absent Member.. Mediocre123 Absent Member..
Absent Member..

Re: Error while adding an attachment (PPM 9.13)

Hi Lois,


We have encountered this error before. Try to change the Oracle counter (KNTA_DOCUMENTS_S sequence) to the highest report number in the PPM attachments directory.


The root cause of the "Duplicate" error may be:
1. The file already existed in the attachments directory because the you had older documents with the same ID.
2. When you copied the database, you used the existing PPM file system (did not copy PPM_HOME) with higher numbers and thus the conflict.
Note: In both examples, a true clone of the PROD PPM instance was not made.