Changes to the community structure and the menu bar
Significant changes have happened to the structure of our community and our drop down menu bar. READ ABOUT IT HERE
Project and Portfolio Management User Discussions
cancel

Issue with Multi select filter in Reports

Highlighted
ShravanK Super Contributor.
Super Contributor.

Issue with Multi select filter in Reports

Hi Everyone,


While we are checking some of the reports in our new PPM 9.42 environment, we found that reports are failing to execute when we have value in multi select filter field.

Previously when we are in PPM 9.31, the multi select field value is delimited with "#@#" and based on this, we coded our reports also.
But when we migrate to 9.42 environment, the same field value is delimited with "," (comma) and we had to change all the reports that were impacted with this.

Cany anyone please let us know if this is the system design in 9.42 or do we need to configure any parameter in server.conf file to consider as "#@#"

Best Regards,
Shravan

2 REPLIES
Aurobinda  Super Contributor..
 Super Contributor..

Re: Issue with Multi select filter in Reports

Hi Shravan,

Can you please confirm below:

Did you observe this behaviour for multiselect fields in Report Form or as well in request form (/Accorss PPM or only for report types)?

Aurobinda  Super Contributor..
 Super Contributor..

Re: Issue with Multi select filter in Reports

Hi Shravan,
Also, did check in our environment and could not find any such system behaviorial change.
So no changes, from 9.3 to 9.4 considering this aspect.
Please cross check the report configuration in your instance.