Changes to the community structure and the menu bar
Significant changes have happened to the structure of our community and our drop down menu bar. READ ABOUT IT HERE
Project and Portfolio Management User Discussions
cancel

PPM login page won't display post IIS installation

SOLVED
Go to solution
Highlighted
debasish86 Trusted Contributor.
Trusted Contributor.

PPM login page won't display post IIS installation

Hello PPM Gurus,

I just recently cloned the PPM application and installed the IIS. Now i can start PPM but when I hit the base url, it gives me the HTTP 500 URL. In addition, when I browse the site from default site under IIS, it shows me the whole PPM folder structure.

I have attached some of the files for reference. Hoping for a response soon.

Debasish

1 ACCEPTED SOLUTION

Accepted Solutions
Respected Contributor... trejos Respected Contributor...
Respected Contributor...
Solution

Re: PPM login page won't display post IIS installation

Hello Debasish,

My name is Bryan Trejos and I will assist you on this thread.

It seems that root cause is that generated_web.xml does not clean up after this type of processes, upgrades or simple start-up of PPM services, etc.

Please follow the next steps in order to troubleshoot this issue:


1. Please add an empty generated_web.xml /conf/ generated_web.xml
Make sure keep an empty file there.

2. Run the sh kUpdateHtml.sh

3.start PPM 

4 REPLIES
Respected Contributor... trejos Respected Contributor...
Respected Contributor...
Solution

Re: PPM login page won't display post IIS installation

Hello Debasish,

My name is Bryan Trejos and I will assist you on this thread.

It seems that root cause is that generated_web.xml does not clean up after this type of processes, upgrades or simple start-up of PPM services, etc.

Please follow the next steps in order to troubleshoot this issue:


1. Please add an empty generated_web.xml /conf/ generated_web.xml
Make sure keep an empty file there.

2. Run the sh kUpdateHtml.sh

3.start PPM 

Aurobinda  Super Contributor..
 Super Contributor..

Re: PPM login page won't display post IIS installation

Hi Debasish,

Please check below few steps, and make sure all are completed.

1. For the Jakarta folder, Provide ‘Full Control’ to IIS_IUSRS user.
2. Create a file called ‘isapi_redirect.properties’ with the below contents.

-----
# The path to the ISAPI Redirector Extension, relative to the website
# This must be in a virtual directory with execute privileges
extension_uri=/jakarta/isapi_redirect.dll

# Full path to the log file for the ISAPI Redirector
log_file=c:\inetpub\jakarta\isapi.log

# Log level (debug, info, warn, error or trace)
log_level=error

# Full path to the workers.properties file
worker_file=c:\Inetpub\jakarta\workers.properties

# Full path to the uriworkermap.properties file
worker_mount_file=c:\Inetpub\jakarta\uriworkermap.properties

rewrite_rule_file=c:\Inetpub\jakarta\rewrites.properties
-----

3. Copy the ‘workers.properties’ file, ‘uriworkermap.properties’ file from
“$PPM_HOME\integration\webserverplugins\configuration” to ‘C:\inetpub\jakarta’.

4. Configure the workers.properties file. For now let us configure for one PPM Node. Only the enabled lines mentoined below.

----
worker.list=load_balancer

worker.HPPPM.host=host1
worker.HPPPM.port=8010
worker.HPPPM.type=ajp13
worker.HPPPM.lbfactor=1

worker.load_balancer.type=lb
worker.load_balancer.balanced_workers=HPPPM
----


HPPPM -> It is PPM User Node name.
host1 -> Hostname of windows server 2012R2.
8010 -> It is EXTERNAL_WEB_PORT for user node HPPPM.

Used the default type ‘ajp13’ and default lbfactor ‘1’

Add the below line in server.conf file.

com.kintana.core.server.EXTERNAL_WEB_PORT=8010

(The affected file is in $PPM_HOME\server\HPPPM\deploy\jbossweb-tomcat55.sar\server.xml) So do the modification only in server.conf and then run kUpdateHTML.sh.

Now workers.properties is configured successfully for first user node.

5.Configure uriworkermap.properties. The enabled lines mentioned below.

----
/itg/*=load_balancer
/dashboard/*=load_balancer
/reports/*=load_balancer
/logs/*=load_balancer
/pdf/*=load_balancer
----

6. Create a file called ‘rewrites.properties’ and isapi.log under C:\inetpub\jakarta and create a file called ‘web.config’ under same directory with the following contents.

----
<?xml version="1.0" encoding="UTF-8"?>
<configuration>
<system.webServer>
<httpProtocol>
<customHeaders>
<remove name="X-Powered-By" />
</customHeaders>
</httpProtocol>
<handlers accessPolicy="Read, Execute, Script">
<remove name="ISAPI-dll" />
<add name="ISAPI-dll" path="*.dll" verb="*" modules="IsapiModule" scriptProcessor="C:\inetpub\jakarta\isapi_redirect.dll" resourceType="Either" requireAccess="Execute" allowPathInfo="true" />
</handlers>
<httpRedirect enabled="false" destination="isapi_redirect.dll" exactDestination="false" />
</system.webServer>
</configuration>
----

Now you should have 7 files under the jakarta directory.

Once all done or verified.

7.Open services.msc

Stop and Start the following services.
a.IIS Admin Service.
b.World Wide Web Publishing Service.

8. Open IIS Manager, Stop and Start the IIS Server.
9. Open Browser and input the following URL.
http://host1.

It must load the IIS homepage.
10. Now try to load ppm URL:
http://host1/itg/dashboard/app/portal/pageview.jsp

It should load ppm home page.

Note:
1. Please update the above paths(if required) according to your environment setup.
2. If still issue persistes, please share us the steps which you have already done. We need to identify if something is missing.

Aurobinda  Super Contributor..
 Super Contributor..

Re: PPM login page won't display post IIS installation

Hi Debasish,

Also, please delete the server.log file (take backup-optional) so that, clean server.log file will generate. From the server log file, there are lot of errors related to port unavalability error. Please check on that and update the port numbers in server.conf file and worker.properties file accordingly. 

debasish86 Trusted Contributor.
Trusted Contributor.

Re: PPM login page won't display post IIS installation

Hello Aurobinda and Bryan,

Thank you for your valuable inputs but seems like Bryan's suggestion helped to solve the issue. generated_web.xml was stopping or in a way blocking from the page to be displayed. I just cleaned up the file and ran the kUpdateHtml and it worked absolutely fine. 

Thank you guys for the help

Debasish