Maintenance is complete- We've moved from the saas.hpe.com domain to softwaregrp.com click to read more
As part of our journey to complete our separation work and our future integration with Micro Focus, we've now updated our domain for the community. This is an interim step, which will be followed by a series of future update / improvements: - Piloting Idea boards - Refreshing the entire UI. (more to come later) - and more
Quality Center / ALM Practitioners Forum
cancel

HELP - CRITICAL BUG HP ALM 12.01

Highlighted
Gregoire57
Super Contributor.

HELP - CRITICAL BUG HP ALM 12.01

Hello,

 

Am using HP ALM 12.01

am starting to run an IOQ for my company, and am currently facing a critical bug: one step is embedded into a instance, but this step is not part of any test within the test Plan: This step was part of a test, which have been deleted from the project: I am 100% sure that this test is not existing anymore in the project

As you can see on the attached snapshot, there is no "source test"

This bug occured once, but has stopped without any action from our side.

Does anybody has already experienced this issue and know the route cause?

How to fix it?

 

Thanks in advance for your kind support!

 

Gregoire

3 REPLIES
Jan Czajkowski
Acclaimed Contributor.

Re: HELP - CRITICAL BUG HP ALM 12.01

I don't think this is a serious problem - rather a refresh problem? I guess you deleted the source test for the called step, then selected Continue Manual Run? The run still contains a reference to the deleted test case, and thus you may see the source test as non-existent.

After refreshing, the hyperlink reference to the deleted test will be replaced by a text string.

Jan Czajkowski

[Please do not contact me off line for receiving support. Use the forum!]
Gregoire57
Super Contributor.

Re: HELP - CRITICAL BUG HP ALM 12.01

Hello Jan,

 

thanks for your prompt reply

As additional details:

1. No "called test" has never been used to the "Corrupted test"

2. I didnt  "Continue any Manual Run" ->This appeared while lauching a totally new run of the same instance.

3. If a right click on the instance and go to test->The unexpected step is not visible in the test, from the test plan module.

4. By trying to perform advanced search from the T.Plan: The step doesnt exist anymore within the project (This step was part of a test I used for a demo. I removed this Test more than 3 months ago

5.The same instance is "corrupted" hazardously: e.g Monday this embedded step is appearing, Tuesday not: Cannot be a refresh issue.

 

6. I have copied the "corrupted" test in the Test Plan

I have executed the new copied test in the Lab

The non expected step is still embedded in both instances (instances coming from initial and copied test), but not present in none of these 2 tests in the T.Plan module.

7. I have generated  into an excel the embedded Test Step ID from runs. This Test Step ID is not visible while am generating test steps ID from T.Plan

 

 

Gregoire57
Super Contributor.

Re: HELP - CRITICAL BUG HP ALM 12.01

Dears,

 

I managed to found out the "corrupted steps" at the DB level, although this step is not present in the Test Plan anymore.

Can anybody support on building a DQL query to entirely remove the steps from the DB level?

The corrupted steps to be remobed are the ones circled in red

 

Many thanks in advance!!