Maintenance is complete- We've moved from the saas.hpe.com domain to softwaregrp.com click to read more
As part of our journey to complete our separation work and our future integration with Micro Focus, we've now updated our domain for the community. This is an interim step, which will be followed by a series of future update / improvements: - Piloting Idea boards - Refreshing the entire UI. (more to come later) - and more
Quality Center / ALM Practitioners Forum
cancel

Requirement System Field displayed in Test Plan details

Highlighted
Mozza
Frequent Contributor.

Requirement System Field displayed in Test Plan details

ALM 12.53

I need to display information that is setup in the Requirements in the Test as follows

Requirements has system field - RQ_TARGET_RCYC;   Label: Target Cycle,  Type: Number

I have created a user field in Test - TS_USER_03;  Plan Label: Target Cycle;  Type: Number

I have the fields displaying as needed in the Test details area

Setup the following for the value to flow through from Requirement to Test when using Requirements => Convert to Tests

Sub Test_New
  On Error Resume Next
    Test_Fields.Field("TS_USER_03").Value = Req_Fields.Field("RQ_TARGET_RCYC").Value
  On Error GoTo 0
End Sub

This didn't work, so I tried Test - TS_USER_03;  Plan Label: Target Cycle;  Type: String

The fields are still blank.

Any ideas?

Note: This works perfectly for a Requirement User Field to Test User Field 

Test_Fields.Field("TS_USER_02").Value = Req_Fields.Field("RQ_USER_04").Value 

 

1 REPLY
Mozza
Frequent Contributor.

Re: Requirement System Field displayed in Test Plan details

Assuming that this is NOT possible

No responses and even Support don't respond to ticket raised