Systems Management (OpenView-OP Mgmt) User Discussions
cancel

getting error on OMW while hitting " ovcm -listpending -l"

cool Trusted Contributor.
Trusted Contributor.

getting error on OMW while hitting " ovcm -listpending -l"

Hi Team,

i am getting below while hitting "ovcm -listpending -l" command on OMW 9.x please help me.

C:\Users\nocadmin>ovcm -listpending -l
ERROR: (sec.cm.client-55) Call to server failed.
(bbc-431) HttpOutputRequestImpl::ProcessRedirection()
HttpStatus::NotFound : caught ServiceUnknownException. There is no
server process registered for address: https://localhost/
com.hp.ov.sec.cm.certificateserver/certreqhandler/.

6 REPLIES
nicnictout Outstanding Contributor.
Outstanding Contributor.

Re: getting error on OMW while hitting " ovcm -listpen

Hello,

 

did you check that ovcm service is correctly running on the manager. 

I know there are some bugs on OMW9, and HP create a hotfix, take a look about available patch.

Sandy19  Frequent Contributor..
 Frequent Contributor..

Re: getting error on OMW while hitting " ovcm -listpen

Open command prompt , Run as adminstrator, and run the  command

cool Trusted Contributor.
Trusted Contributor.

Re: getting error on OMW while hitting " ovcm -listpen

tried but same error. :(

nicnictout Outstanding Contributor.
Outstanding Contributor.

Re: getting error on OMW while hitting " ovcm -listpen

Hello,

 

first of all, check that your process ovcm is running, otherwise you won't be able to list pending certificates.

vpstat -3 -l

check that ovcm is running. If not, just start with:

ovc -start ovcm

 

This will solve temporary your issue, but you have to check in all available hotfix for omw9, because there is a known bug on ovcm and HP provide a patch to fix it, unfortunately i do not remember the patch reference.

cool Trusted Contributor.
Trusted Contributor.

Re: getting error on OMW while hitting " ovcm -listpen

Hi,

i have checked after putting "vpstat -3 -l" command but unable see ovcm service. i have attached snap for more details.

nicnictout Outstanding Contributor.
Outstanding Contributor.

Re: getting error on OMW while hitting " ovcm -listpen

Hello,

well i do not have an OMW under hand to check it, but your list of services seems quite short in my opinion.

Could you look into oainstall.log of your manager and check that all msi package are correctly installed as listed in OM documentation ? For me it missing at least the package OvcertServ (ovcs/m, i do not remember exactly but name is quite intuitive)

Did you proceed to an upgrade of agent manager recently? install a new patch ? Post vpstat -p output it could be usefull ;)